Partial Outage
Incident Report for ProjectManager
Resolved
The incident has been resolved.
Posted May 20, 2024 - 13:20 PDT
Monitoring
A fix has been implemented and we are monitoring all systems.
Posted May 20, 2024 - 13:09 PDT
Identified
We have identified the issue and a fix is being implemented.
Posted May 20, 2024 - 13:03 PDT
Investigating
We are currently investigating an issue where changes are not saving and appearing as expected.
Posted May 20, 2024 - 12:50 PDT
This incident affected: Platform Status.