Delay in processing of task changes
Incident Report for ProjectManager
Resolved
The issue has been identified and the problem has been resolved. This performance degradation affected a small subset of projects.
Posted Mar 05, 2024 - 01:25 PST
Investigating
We are currently investigating an issue where the task processing is delayed.
Posted Mar 05, 2024 - 01:04 PST
This incident affected: Platform Status.