Partial Outage
Incident Report for ProjectManager
Resolved
This incident has been resolved.
Posted Jun 24, 2024 - 09:31 PDT
Monitoring
We have released a fix for the Workload page not loading and will continue to monitor all systems.
Posted Jun 24, 2024 - 09:14 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2024 - 09:10 PDT
Investigating
We are currently investigating reports of the Workload page not loading in the product.
Posted Jun 24, 2024 - 08:40 PDT
This incident affected: Platform Status.